summaryrefslogtreecommitdiffstats
path: root/guix
diff options
context:
space:
mode:
authorTing-Wei Lan <lantw44@gmail.com>2019-09-18 14:19:41 +0800
committerTing-Wei Lan <lantw44@gmail.com>2019-09-18 14:19:41 +0800
commit51ce7e4cc1779e4d575f1a9bb119006cf54ee9f2 (patch)
treef9a851914858d44ff6c3b40e36d0965f1e5da1db /guix
parentb06e527ce4c0b2064d33e98e42ed74048bae4683 (diff)
downloadAUR4-PKGBUILD-51ce7e4cc1779e4d575f1a9bb119006cf54ee9f2.tar
AUR4-PKGBUILD-51ce7e4cc1779e4d575f1a9bb119006cf54ee9f2.tar.gz
AUR4-PKGBUILD-51ce7e4cc1779e4d575f1a9bb119006cf54ee9f2.tar.bz2
AUR4-PKGBUILD-51ce7e4cc1779e4d575f1a9bb119006cf54ee9f2.tar.lz
AUR4-PKGBUILD-51ce7e4cc1779e4d575f1a9bb119006cf54ee9f2.tar.xz
AUR4-PKGBUILD-51ce7e4cc1779e4d575f1a9bb119006cf54ee9f2.tar.zst
AUR4-PKGBUILD-51ce7e4cc1779e4d575f1a9bb119006cf54ee9f2.zip
guix: 1.0.1 -> 1.0.1+3489+g0ed97e6980
Update to the latest commit mentioned in the source code of guix itself. This should fix failed tests and the 'guix pull' crash. https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/package-management.scm?id=f8ddfb505a51a2c794531e090dd7ee97022d1096#n121
Diffstat (limited to 'guix')
-rw-r--r--guix/.SRCINFO20
-rw-r--r--guix/PKGBUILD36
2 files changed, 31 insertions, 25 deletions
diff --git a/guix/.SRCINFO b/guix/.SRCINFO
index f4df99c..dbce9ed 100644
--- a/guix/.SRCINFO
+++ b/guix/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = guix
pkgdesc = A purely functional package manager for the GNU system
- pkgver = 1.0.1
- pkgrel = 2
+ pkgver = 1.0.1+3489+g0ed97e6980
+ pkgrel = 1
url = https://www.gnu.org/software/guix/
install = guix.install
arch = x86_64
@@ -10,9 +10,11 @@ pkgbase = guix
license = GPL3
makedepends = bash-completion
makedepends = fish
- makedepends = guile-json1
+ makedepends = git
+ makedepends = guile-json>=3
makedepends = guile-ssh>=0.10.2
makedepends = help2man
+ makedepends = po4a
depends = guile>=2.2.4
depends = guile-gcrypt
depends = guile-git-lib
@@ -21,18 +23,16 @@ pkgbase = guix
depends = bzip2
depends = gnutls
depends = libgcrypt
+ depends = lzlib
depends = zlib
optdepends = bash-completion: to enable bash programmable completion
- optdepends = guile-json1: to import packages from cpan, gem, pypi
+ optdepends = guile-json: to import packages from cpan, gem, pypi
optdepends = guile-ssh: to offload builds to other machines
options = !strip
- source = https://ftp.gnu.org/gnu/guix/guix-1.0.1.tar.gz
- source = https://ftp.gnu.org/gnu/guix/guix-1.0.1.tar.gz.sig
+ source = git+https://git.savannah.gnu.org/git/guix.git#commit=0ed97e69805253656df929a6ad678016aa81f08a
validpgpkeys = 3CE464558A84FDC69DB40CFB090B11993D9AEBB5
- sha1sums = f6e32b17e034124edeec11d841e687ba0ee59242
- sha1sums = 551bf83df2771573403bcd1fe048d74dcb98e4cf
- sha256sums = 3939b6cfa11661290fee0b82f91d2a0d39c2e36fdf4e53d8afd31dd34430ea5f
- sha256sums = 15e59f63f95527f7126ed85c66435850a82c17f015568e1432f1fcbabc70dabb
+ sha1sums = SKIP
+ sha256sums = SKIP
pkgname = guix
diff --git a/guix/PKGBUILD b/guix/PKGBUILD
index 007b3ab..b6ed408 100644
--- a/guix/PKGBUILD
+++ b/guix/PKGBUILD
@@ -6,8 +6,8 @@
# gpg --recv-keys 3CE464558A84FDC69DB40CFB090B11993D9AEBB5
pkgname=guix
-pkgver=1.0.1
-pkgrel=2
+pkgver=1.0.1+3489+g0ed97e6980
+pkgrel=1
pkgdesc="A purely functional package manager for the GNU system"
arch=('x86_64' 'i686' 'armv7h')
url="https://www.gnu.org/software/guix/"
@@ -16,9 +16,11 @@ options=('!strip')
makedepends=(
'bash-completion'
'fish'
- 'guile-json1'
+ 'git'
+ 'guile-json>=3'
'guile-ssh>=0.10.2'
- 'help2man')
+ 'help2man'
+ 'po4a')
depends=(
'guile>=2.2.4'
'guile-gcrypt'
@@ -28,26 +30,32 @@ depends=(
'bzip2'
'gnutls'
'libgcrypt'
+ 'lzlib'
'zlib')
optdepends=(
'bash-completion: to enable bash programmable completion'
- 'guile-json1: to import packages from cpan, gem, pypi'
+ 'guile-json: to import packages from cpan, gem, pypi'
'guile-ssh: to offload builds to other machines')
+_commit=0ed97e69805253656df929a6ad678016aa81f08a
source=(
- "https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz"{,.sig})
+ "git+https://git.savannah.gnu.org/git/${pkgname}.git#commit=${_commit}")
install="${pkgname}.install"
sha1sums=(
- 'f6e32b17e034124edeec11d841e687ba0ee59242'
- '551bf83df2771573403bcd1fe048d74dcb98e4cf')
+ 'SKIP')
sha256sums=(
- '3939b6cfa11661290fee0b82f91d2a0d39c2e36fdf4e53d8afd31dd34430ea5f'
- '15e59f63f95527f7126ed85c66435850a82c17f015568e1432f1fcbabc70dabb')
+ 'SKIP')
validpgpkeys=('3CE464558A84FDC69DB40CFB090B11993D9AEBB5')
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ git describe --exclude 'bootstrap-*' --tags | sed -e 's/-/+/g' -e 's/^v//g'
+}
+
build() {
local bash_completion_dir="$(pkg-config --variable=completionsdir bash-completion)"
local fish_completion_dir="$(pkg-config --variable=completionsdir fish)"
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}"
+ ./bootstrap
./configure --prefix=/usr --sbindir=/usr/bin --sysconfdir=/etc \
--libexecdir=/usr/lib --localstatedir=/var \
--with-bash-completion-dir="${bash_completion_dir}" \
@@ -58,7 +66,7 @@ build() {
}
check() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}"
# Check whether the current working directory is too long
local cwd_str="$(pwd)"
local cwd_len="${#cwd_str}"
@@ -76,7 +84,7 @@ check() {
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}"
make DESTDIR="${pkgdir}" install
# Remove unused upstart service files
rm -r "${pkgdir}/usr/lib/upstart"
@@ -116,8 +124,6 @@ package() {
eval 'options=()'
cd "${pkgdir}/usr/bin"
tidy_strip
- cd "${pkgdir}/usr/lib/guix"
- tidy_strip
eval 'options=("!strip")'
# Make sure bootstrap binaries are not modified
cd "${pkgdir}/usr/share/guile/site/2.2/gnu/packages/bootstrap"