summaryrefslogtreecommitdiffstats
path: root/guix
diff options
context:
space:
mode:
authorTing-Wei Lan <lantw44@gmail.com>2015-07-24 12:39:51 +0800
committerTing-Wei Lan <lantw44@gmail.com>2015-07-24 14:37:09 +0800
commit502eb2004472220f9004969e25f00ee45a4f9b7d (patch)
tree8699a380a66133582fd78ebe350c21f15355c565 /guix
parent08bdc23146a04b0a7b2eede848a193e17bd255c4 (diff)
downloadAUR4-PKGBUILD-502eb2004472220f9004969e25f00ee45a4f9b7d.tar
AUR4-PKGBUILD-502eb2004472220f9004969e25f00ee45a4f9b7d.tar.gz
AUR4-PKGBUILD-502eb2004472220f9004969e25f00ee45a4f9b7d.tar.bz2
AUR4-PKGBUILD-502eb2004472220f9004969e25f00ee45a4f9b7d.tar.lz
AUR4-PKGBUILD-502eb2004472220f9004969e25f00ee45a4f9b7d.tar.xz
AUR4-PKGBUILD-502eb2004472220f9004969e25f00ee45a4f9b7d.tar.zst
AUR4-PKGBUILD-502eb2004472220f9004969e25f00ee45a4f9b7d.zip
guix: Remove the systemd service file written by me
Upstream already provides a better systemd service file.
Diffstat (limited to 'guix')
-rw-r--r--guix/.SRCINFO4
-rw-r--r--guix/PKGBUILD11
-rw-r--r--guix/guix.install12
-rw-r--r--guix/guix.service10
4 files changed, 16 insertions, 21 deletions
diff --git a/guix/.SRCINFO b/guix/.SRCINFO
index ffdf991..771f52a 100644
--- a/guix/.SRCINFO
+++ b/guix/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = guix
pkgdesc = GNU guix is a purely functional package manager
pkgver = 0.8.3
- pkgrel = 1
+ pkgrel = 2
url = https://www.gnu.org/software/guix/
install = guix.install
arch = x86_64
@@ -17,10 +17,8 @@ pkgbase = guix
optdepends = emacs: to enable Emacs Interface
source = ftp://alpha.gnu.org/gnu/guix/guix-0.8.3.tar.gz
source = ftp://alpha.gnu.org/gnu/guix/guix-0.8.3.tar.gz.sig
- source = guix.service
sha256sums = dfea48f13e6584db812c24746467eb21cb0553a2f5860e1fe40d4e06e4b4c092
sha256sums = 411b3b850191f1fc701e9a2178aa02a403c44baa59b58a6ef9c18237a10fd049
- sha256sums = d0a014de859c4f5d6f760be84991b88f4855ead933368f3ab815a1deabc361ce
pkgname = guix
diff --git a/guix/PKGBUILD b/guix/PKGBUILD
index 3fc7d7f..7995321 100644
--- a/guix/PKGBUILD
+++ b/guix/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=guix
pkgver=0.8.3
-pkgrel=1
+pkgrel=2
pkgdesc="GNU guix is a purely functional package manager"
arch=('x86_64' 'i686')
url="https://www.gnu.org/software/guix/"
@@ -24,12 +24,10 @@ optdepends=(
'bash-completion: to enable bash programmable completion'
'emacs: to enable Emacs Interface')
source=(
- "ftp://alpha.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz"{,.sig}
- "guix.service")
+ "ftp://alpha.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz"{,.sig})
install="${pkgname}.install"
sha256sums=('dfea48f13e6584db812c24746467eb21cb0553a2f5860e1fe40d4e06e4b4c092'
- '411b3b850191f1fc701e9a2178aa02a403c44baa59b58a6ef9c18237a10fd049'
- 'd0a014de859c4f5d6f760be84991b88f4855ead933368f3ab815a1deabc361ce')
+ '411b3b850191f1fc701e9a2178aa02a403c44baa59b58a6ef9c18237a10fd049')
validpgpkeys=('3CE464558A84FDC69DB40CFB090B11993D9AEBB5')
build() {
@@ -51,7 +49,4 @@ check() {
package() {
cd ${srcdir}/${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
- mkdir -p ${pkgdir}/usr/lib/systemd/system
- install -m 644 "${srcdir}/guix.service" \
- ${pkgdir}/usr/lib/systemd/system/guix.service
}
diff --git a/guix/guix.install b/guix/guix.install
index 2621d0f..54f7659 100644
--- a/guix/guix.install
+++ b/guix/guix.install
@@ -2,6 +2,18 @@ infodir=usr/share/info
file=guix.info
post_install() {
+ echo "Guix 0.8.3 already provides a systemd service file in its release,"
+ echo "so the one included in AUR package is now removed. Please use the"
+ echo "following commands to keep your installation compatible with the"
+ echo "new service file:"
+ echo
+ echo " systemctl disable guix"
+ echo " systemctl enable guix-daemon"
+ echo " groupmod -n guixbuild guix-builder"
+ echo " usermod -l guixbuild guix-builder"
+ echo
+ echo "If you have /etc/systemd/system/guix.service.d, please also remember"
+ echo "to review its content and rename it to guix-daemon.service.d."
[[ -x usr/bin/install-info ]] || return 0
install-info "$infodir/$file.gz" "$infodir/dir" 2> /dev/null
}
diff --git a/guix/guix.service b/guix/guix.service
deleted file mode 100644
index 7804793..0000000
--- a/guix/guix.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=GNU Guix package manager
-
-[Service]
-ExecStart=/usr/bin/guix-daemon --build-users-group=guix-builder
-KillMode=process
-
-[Install]
-WantedBy=multi-user.target
-