summaryrefslogtreecommitdiffstats
path: root/guix
diff options
context:
space:
mode:
authorTing-Wei Lan <lantw44@gmail.com>2015-11-06 00:31:41 +0800
committerTing-Wei Lan <lantw44@gmail.com>2015-11-06 00:31:41 +0800
commit1d6a1f059c735e9907fe8597a1932a5f7e48670a (patch)
treecfb84096472ef0ef5627da9f8179e9ed3d37384c /guix
parent0ea52e4521e831bf7a1732d38f2a4166e0d95d51 (diff)
downloadAUR4-PKGBUILD-1d6a1f059c735e9907fe8597a1932a5f7e48670a.tar
AUR4-PKGBUILD-1d6a1f059c735e9907fe8597a1932a5f7e48670a.tar.gz
AUR4-PKGBUILD-1d6a1f059c735e9907fe8597a1932a5f7e48670a.tar.bz2
AUR4-PKGBUILD-1d6a1f059c735e9907fe8597a1932a5f7e48670a.tar.lz
AUR4-PKGBUILD-1d6a1f059c735e9907fe8597a1932a5f7e48670a.tar.xz
AUR4-PKGBUILD-1d6a1f059c735e9907fe8597a1932a5f7e48670a.tar.zst
AUR4-PKGBUILD-1d6a1f059c735e9907fe8597a1932a5f7e48670a.zip
guix: 0.8.3 -> 0.9.0
Disable tests that don't work on kernels without user namespace support.
Diffstat (limited to 'guix')
-rw-r--r--guix/.SRCINFO15
-rw-r--r--guix/PKGBUILD16
2 files changed, 18 insertions, 13 deletions
diff --git a/guix/.SRCINFO b/guix/.SRCINFO
index 771f52a..ea734ee 100644
--- a/guix/.SRCINFO
+++ b/guix/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = guix
pkgdesc = GNU guix is a purely functional package manager
- pkgver = 0.8.3
- pkgrel = 2
+ pkgver = 0.9.0
+ pkgrel = 1
url = https://www.gnu.org/software/guix/
install = guix.install
arch = x86_64
@@ -9,16 +9,17 @@ pkgbase = guix
license = GPL
makedepends = bash-completion
makedepends = emacs
- depends = guile>=2.0.5
+ makedepends = guile-json
+ depends = guile>=2.0.7
depends = sqlite>=3.6.19
depends = bzip2
depends = libgcrypt
optdepends = bash-completion: to enable bash programmable completion
optdepends = emacs: to enable Emacs Interface
- source = ftp://alpha.gnu.org/gnu/guix/guix-0.8.3.tar.gz
- source = ftp://alpha.gnu.org/gnu/guix/guix-0.8.3.tar.gz.sig
- sha256sums = dfea48f13e6584db812c24746467eb21cb0553a2f5860e1fe40d4e06e4b4c092
- sha256sums = 411b3b850191f1fc701e9a2178aa02a403c44baa59b58a6ef9c18237a10fd049
+ source = ftp://alpha.gnu.org/gnu/guix/guix-0.9.0.tar.gz
+ source = ftp://alpha.gnu.org/gnu/guix/guix-0.9.0.tar.gz.sig
+ sha1sums = 765de53aa344a801c3d376cf1e050650cec58039
+ sha1sums = ab25cfdb39ff6d53458c07a8ab9b397a7bc8c9c5
pkgname = guix
diff --git a/guix/PKGBUILD b/guix/PKGBUILD
index ed94480..fda1b9e 100644
--- a/guix/PKGBUILD
+++ b/guix/PKGBUILD
@@ -6,17 +6,18 @@
# gpg --recv-keys 090B11993D9AEBB5
pkgname=guix
-pkgver=0.8.3
-pkgrel=2
+pkgver=0.9.0
+pkgrel=1
pkgdesc="GNU guix is a purely functional package manager"
arch=('x86_64' 'i686')
url="https://www.gnu.org/software/guix/"
license=('GPL')
makedepends=(
'bash-completion'
- 'emacs') # Please remove this if you are not going to use guix in emacs
+ 'emacs' # Please remove this if you are not going to use guix in emacs
+ 'guile-json')
depends=(
- 'guile>=2.0.5'
+ 'guile>=2.0.7'
'sqlite>=3.6.19'
'bzip2'
'libgcrypt')
@@ -26,8 +27,8 @@ optdepends=(
source=(
"ftp://alpha.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz"{,.sig})
install="${pkgname}.install"
-sha256sums=('dfea48f13e6584db812c24746467eb21cb0553a2f5860e1fe40d4e06e4b4c092'
- '411b3b850191f1fc701e9a2178aa02a403c44baa59b58a6ef9c18237a10fd049')
+sha1sums=('765de53aa344a801c3d376cf1e050650cec58039'
+ 'ab25cfdb39ff6d53458c07a8ab9b397a7bc8c9c5')
validpgpkeys=('3CE464558A84FDC69DB40CFB090B11993D9AEBB5')
build() {
@@ -42,6 +43,9 @@ build() {
check() {
cd ${srcdir}/${pkgname}-${pkgver}
+ # Don't run container tests if the kernel doesn't support user namespace
+ zgrep "CONFIG_USER_NS=y" /proc/config.gz || \
+ sed -i 's|tests/guix-environment-container.sh||' Makefile
make check
}