aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorYunchih Chen <yunchih.cat@gmail.com>2018-03-05 10:40:57 +0800
committerYunchih Chen <yunchih.cat@gmail.com>2018-03-05 10:40:57 +0800
commitdd91a91704b76c3f46b841d86f5cedee684e7fa9 (patch)
tree422cdd00ae93fff7b5418966513445a16d232f13 /Makefile.am
parent692a091becf285adbc606758125a735c10c8287d (diff)
downloadnfcollect-dd91a91704b76c3f46b841d86f5cedee684e7fa9.tar
nfcollect-dd91a91704b76c3f46b841d86f5cedee684e7fa9.tar.gz
nfcollect-dd91a91704b76c3f46b841d86f5cedee684e7fa9.tar.bz2
nfcollect-dd91a91704b76c3f46b841d86f5cedee684e7fa9.tar.lz
nfcollect-dd91a91704b76c3f46b841d86f5cedee684e7fa9.tar.xz
nfcollect-dd91a91704b76c3f46b841d86f5cedee684e7fa9.tar.zst
nfcollect-dd91a91704b76c3f46b841d86f5cedee684e7fa9.zip
Switch to new project layout
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index f2b5310..cf6dd98 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,8 @@
bin_PROGRAMS = nfcollect nfextract
-nfcollect_SOURCES = commit.c collect.c common.c nfcollect.c
-nfextract_SOURCES = common.c extract.c nfextract.c
+
+AM_CFLAGS = \
+ -I$(top_srcdir)/include \
+ -Werror -Wall -Wno-address-of-packed-member
+
+nfcollect_SOURCES = lib/common.c lib/commit.c lib/collect.c bin/nfcollect.c
+nfextract_SOURCES = lib/common.c lib/extract.c bin/nfextract.c