aboutsummaryrefslogtreecommitdiffstats
path: root/filter/e-filter-file.c
Commit message (Collapse)AuthorAgeFilesLines
* Consolidate base utility libraries into libeutil.Matthew Barnes2012-12-131-262/+0
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | Evolution consists of entirely too many small utility libraries, which increases linking and loading time, places a burden on higher layers of the application (e.g. modules) which has to remember to link to all the small in-tree utility libraries, and makes it difficult to generate API documentation for these utility libraries in one Gtk-Doc module. Merge the following utility libraries under the umbrella of libeutil, and enforce a single-include policy on libeutil so we can reorganize the files as desired without disrupting its pseudo-public API. libemail-utils/libemail-utils.la libevolution-utils/libevolution-utils.la filter/libfilter.la widgets/e-timezone-dialog/libetimezonedialog.la widgets/menus/libmenus.la widgets/misc/libemiscwidgets.la widgets/table/libetable.la widgets/text/libetext.la This also merges libedataserverui from the Evolution-Data-Server module, since Evolution is its only consumer nowadays, and I'd like to make some improvements to those APIs without concern for backward-compatibility. And finally, start a Gtk-Doc module for libeutil. It's going to be a project just getting all the symbols _listed_ much less _documented_. But the skeletal structure is in place and I'm off to a good start.
* Coding style and whitespace cleanup.Matthew Barnes2012-11-111-1/+1
|
* Coding style and whitespace cleanup.Matthew Barnes2012-08-201-2/+2
|
* Move EAlert* and e-xml-utils references from other part of the code to ↵Srinivasa Ragavan2012-03-031-1/+1
| | | | libevolution-utils.
* Use CamelSExp instead of ESExp in filter, mail.Matthew Barnes2011-11-151-3/+1
|
* Bug #646109 - Fix use of include <config.h> to make sure translations workMilan Crha2011-05-271-0/+2
|
* Coding style cleanups.Matthew Barnes2011-05-091-5/+5
|
* GObject boilerplate cleanup.Matthew Barnes2010-08-251-29/+10
| | | | | | | Prefer thread-safe G_DEFINE_TYPE and G_DEFINE_INTERFACE macros over manual GType registration. This is just a start... lots more to do.
* Rename EError to EAlert to match general use betterJonathon Jongsma2009-12-011-7/+7
| | | | | | | | | | The EError mechanism is used both for error dialogs as well as basic alerts or user prompts, so we should give it a more general name which matches this use. This patch also cleans up a few includes of e-alert.h (formerly e-error.h) that were not actually being used. https://bugzilla.gnome.org/show_bug.cgi?id=602963
* port filter/ classes over to new EError APIJonathon Jongsma2009-12-011-5/+8
| | | | https://bugzilla.gnome.org/show_bug.cgi?id=602963
* Cleanup and rename filter classes.Matthew Barnes2009-10-271-0/+278