aboutsummaryrefslogtreecommitdiffstats
path: root/widgets/e-table/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'widgets/e-table/Makefile.am')
-rw-r--r--widgets/e-table/Makefile.am17
1 files changed, 16 insertions, 1 deletions
diff --git a/widgets/e-table/Makefile.am b/widgets/e-table/Makefile.am
index 14bab7e2f4..1afe8d9f20 100644
--- a/widgets/e-table/Makefile.am
+++ b/widgets/e-table/Makefile.am
@@ -16,6 +16,7 @@ INCLUDES = \
$(GNOME_INCLUDEDIR) \
-DETABLE_GLADEDIR=\"$(gladedir)\" \
-I$(top_srcdir)/widgets/e-text \
+ -I$(top_srcdir)/widgets/e-paned \
-I$(top_srcdir)/e-util \
-I$(top_srcdir) \
-DG_LOG_DOMAIN=\"e-table\"
@@ -92,7 +93,7 @@ libetable_a_SOURCES = \
e-tree-simple.h
noinst_PROGRAMS = \
- table-test table-example-1 table-example-2 table-size-test tree-example-1
+ table-test table-example-1 table-example-2 table-size-test tree-example-1 tree-example-2
table_test_SOURCES = \
test-table.c \
@@ -163,6 +164,20 @@ tree_example_1_LDADD = \
$(top_builddir)/e-util/libeutil.la \
$(GNOME_PRINT_LIBS)
+tree_example_2_SOURCES = \
+ e-tree-example-2.c
+
+tree_example_2_LDFLAGS = `gnome-config --libs gdk_pixbuf` `gnome-config --libs vfs`
+
+tree_example_2_LDADD = \
+ libetable.a \
+ $(EXTRA_GNOME_LIBS) \
+ $(top_builddir)/widgets/e-text/libetext.a \
+ $(top_builddir)/widgets/e-paned/libepaned.a \
+ $(top_builddir)/widgets/misc/libemiscwidgets.a \
+ $(top_builddir)/e-util/libeutil.la \
+ $(GNOME_PRINT_LIBS)
+
icons = \
arrow-down.xpm \
arrow-up.xpm \