aboutsummaryrefslogtreecommitdiffstats
path: root/widgets/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'widgets/Makefile.am')
-rw-r--r--widgets/Makefile.am36
1 files changed, 29 insertions, 7 deletions
diff --git a/widgets/Makefile.am b/widgets/Makefile.am
index d6aa94fb90..35d1bc64a4 100644
--- a/widgets/Makefile.am
+++ b/widgets/Makefile.am
@@ -1,7 +1,29 @@
-noinst_LIBRARIES = \
- e-table-simple.c \
- e-table-simple.h \
- e-table-model.c \
- e-table-model.h \
- e-table-column-model.c \
- e-table-column-model.h \
+guidir = $(datadir)/evolution/gui
+
+gui_DATA = \
+ e-msg-composer-attachment.glade \
+ e-msg-composer.glade
+
+INCLUDES = \
+ -I$(top_srcdir)/camel \
+ -I$(top_builddir)/camel \
+ $(GNOME_INCLUDEDIR)
+
+CPPFLAGS = \
+ -DE_GUIDIR=\"$(guidir)\"
+
+noinst_LTLIBRARIES = \
+ libevolutionwidgets.la
+
+libevolutionwidgets_la_SOURCES = \
+ e-msg-composer-address-entry.c \
+ e-msg-composer-address-entry.h \
+ e-msg-composer-attachment-bar.c \
+ e-msg-composer-attachment-bar.h \
+ e-msg-composer-attachment.c \
+ e-msg-composer-attachment.h \
+ e-msg-composer-hdrs.c \
+ e-msg-composer-hdrs.h \
+ e-msg-composer.c \
+ e-msg-composer.h
+