aboutsummaryrefslogtreecommitdiffstats
path: root/ui/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ui/Makefile.am')
-rw-r--r--ui/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/ui/Makefile.am b/ui/Makefile.am
index 6746249f6f..aec14eb600 100644
--- a/ui/Makefile.am
+++ b/ui/Makefile.am
@@ -12,3 +12,9 @@ uidir = $(datadir)/gnome/ui
ui_DATA = $(XML_FILES)
EXTRA_DIST = $(XML_FILES)
+
+BUILT_SOURCES=$(XML_FILES:.xml=.h)
+
+%.h : %.xml
+ bonobo-ui-extract $^ > $@
+