aboutsummaryrefslogtreecommitdiffstats
path: root/shell/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'shell/test/Makefile.am')
-rw-r--r--shell/test/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/shell/test/Makefile.am b/shell/test/Makefile.am
new file mode 100644
index 0000000000..266685064c
--- /dev/null
+++ b/shell/test/Makefile.am
@@ -0,0 +1,35 @@
+component_LTLIBRARIES = libevolution-test.la
+
+INCLUDES = \
+ -I$(top_srcdir)/shell \
+ -I$(top_srcdir)/widgets/misc \
+ -I$(top_builddir)/shell \
+ -DG_LOG_DOMAIN=\"evolution-test\" \
+ $(EVOLUTION_TEST_CFLAGS)
+
+libevolution_test_la_SOURCES = \
+ evolution-test-component.c \
+ evolution-test-component.h
+
+libevolution_test_la_LIBADD = \
+ $(top_builddir)/shell/libeshell.la \
+ $(EVOLUTION_TEST_LIBS)
+
+libevolution_test_la_LDFLAGS = \
+ -avoid-version -module $(NO_UNDEFINED)
+
+testserver_in_files = GNOME_Evolution_Test.server.in.in
+testserver_DATA = $(testserver_in_files:.server.in.in=.server)
+testserverdir = $(serverdir)
+@EVO_SERVER_RULE@
+@INTLTOOL_SERVER_RULE@
+
+BUILT_SOURCES = $(testserver_DATA)
+CLEANFILES = $(BUILT_SOURCES)
+
+EXTRA_DIST = \
+ $(testserver_in_files) \
+ GNOME_Evolution_Test.server.in.in
+
+dist-hook:
+ cd $(distdir); rm -f $(BUILD_SOURCES)