aboutsummaryrefslogtreecommitdiffstats
path: root/shell/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'shell/test/Makefile.am')
-rw-r--r--shell/test/Makefile.am21
1 files changed, 2 insertions, 19 deletions
diff --git a/shell/test/Makefile.am b/shell/test/Makefile.am
index 266685064c..f667ee42fe 100644
--- a/shell/test/Makefile.am
+++ b/shell/test/Makefile.am
@@ -1,4 +1,4 @@
-component_LTLIBRARIES = libevolution-test.la
+module_LTLIBRARIES = libevolution-test.la
INCLUDES = \
-I$(top_srcdir)/shell \
@@ -8,8 +8,7 @@ INCLUDES = \
$(EVOLUTION_TEST_CFLAGS)
libevolution_test_la_SOURCES = \
- evolution-test-component.c \
- evolution-test-component.h
+ evolution-test-module.c
libevolution_test_la_LIBADD = \
$(top_builddir)/shell/libeshell.la \
@@ -17,19 +16,3 @@ libevolution_test_la_LIBADD = \
libevolution_test_la_LDFLAGS = \
-avoid-version -module $(NO_UNDEFINED)
-
-testserver_in_files = GNOME_Evolution_Test.server.in.in
-testserver_DATA = $(testserver_in_files:.server.in.in=.server)
-testserverdir = $(serverdir)
-@EVO_SERVER_RULE@
-@INTLTOOL_SERVER_RULE@
-
-BUILT_SOURCES = $(testserver_DATA)
-CLEANFILES = $(BUILT_SOURCES)
-
-EXTRA_DIST = \
- $(testserver_in_files) \
- GNOME_Evolution_Test.server.in.in
-
-dist-hook:
- cd $(distdir); rm -f $(BUILD_SOURCES)