aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 9ec1771914..fd608ef3cc 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -318,6 +318,9 @@ install-data-local:
install-evolution:
$(mkinstalldirs) $(DESTDIR)$(bindir)
$(LIBTOOL) --mode=install $(INSTALL_PROGRAM) evolution $(DESTDIR)$(bindir)/evolution-$(BASE_VERSION)
+if DEFAULT_BINARY
+ cd $(DESTDIR)$(bindir) && rm -f evolution && $(LN_S) evolution-$(BASE_VERSION) evolution
+endif
if HAVE_DTAPPINTEGRATE
@@ -332,6 +335,7 @@ install-exec-local: install-evolution
endif
+
# GLib marshalling cruft
e-shell-marshal.h: e-shell-marshal.list