aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index a4d4776e76..d7b69b32e5 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -54,3 +54,13 @@ EXTRA_DIST = Evolution.idl \
Shell.idl \
evolution-service-repository.idl
+if ENABLE_PURIFY
+PLINK = $(LIBTOOL) --mode=link $(PURIFY) $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) -o $@
+
+all-local: evolution.pure
+
+evolution.pure: evolution
+ @rm -f evolution.pure
+ $(PLINK) $(evolution_LDFLAGS) $(evolution_OBJECTS) $(evolution_LDADD) $(LIBS)
+
+endif