aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 8e38448ad5..f2891e6fbb 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -269,6 +269,18 @@ icons = \
check-filled.xpm \
check-missing.xpm
+# GConf schemas
+
+schemadir = $(GCONF_SCHEMA_FILE_DIR)
+schema_DATA = apps_evolution_shell.schemas
+
+install-data-local:
+ if test -z "$(DESTDIR)" ; then \
+ for p in $(schema_DATA) ; do \
+ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(srcdir)/$$p; \
+ done \
+ fi
+
# GLib marshalling cruft