aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 1ad4872aad..f7d4476eac 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -32,11 +32,14 @@ evolution_SOURCES = \
e-shell-view-menu.c \
e-shell-view-menu.h \
e-shortcut.c \
- e-shortcut.h
+ e-shortcut.h \
+ evolution-service-repository.c \
+ evolution-service-repository.h
+
Evolution-impl.o: Evolution.h
-$(EVOLUTION_CORBA_GENERATED): Evolution.idl
+$(EVOLUTION_CORBA_GENERATED): Evolution.idl evolution-service-repository.idl
orbit-idl -I`$(GNOME_CONFIG) --datadir`/idl -I$(srcdir) $(srcdir)/Evolution.idl
evolution_LDADD = \
@@ -45,4 +48,7 @@ evolution_LDADD = \
../e-util/libeutil.la \
$(BONOBO_GNOME_LIBS)
-EXTRA_DIST = Evolution.idl
+EXTRA_DIST = Evolution.idl \
+ Shell.idl \
+ evolution-service-repository.idl
+