aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index d52972c02a..b6eb99cba7 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -13,8 +13,6 @@ INCLUDES = \
-DEVOLUTION_GLADEDIR=\"$(datadir)/evolution/glade\" \
-DG_LOG_DOMAIN=\"evolution-shell\"
-CLEANFILES = $(IDL_GENERATED)
-
# CORBA stuff
IDLS = \
@@ -162,3 +160,10 @@ evolution.pure: evolution
$(PLINK) $(evolution_LDFLAGS) $(evolution_OBJECTS) $(evolution_LDADD) $(LIBS)
endif
+
+CLEANFILES += $(IDL_GENERATED)
+BUILT_SOURCES = $(IDL_GENERATED)
+
+dist-hook:
+ cd $(distdir); rm -f $(BUILT_SOURCES)
+