aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am20
1 files changed, 14 insertions, 6 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 5fc76a57f5..d9b4a669ba 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -315,9 +315,21 @@ install-data-local:
done \
fi
-install-exec-local:
+install-evolution:
$(LIBTOOL) --mode=install $(INSTALL_PROGRAM) evolution $(DESTDIR)$(bindir)/evolution-$(BASE_VERSION)
+if HAVE_DTAPPINTEGRATE
+
+install-exec-local: install-evolution
+ mkdir -p $(DESTDIR)$(libexecdir)
+ mv $(DESTDIR)$(bindir)/evolution-$(BASE_VERSION) $(DESTDIR)$(libexecdir)/evolution-$(BASE_VERSION)
+ $(INSTALL_PROGRAM) evolution-nognome $(DESTDIR)$(bindir)/evolution-$(BASE_VERSION)
+
+else
+
+install-exec-local: install-evolution
+
+endif
# GLib marshalling cruft
@@ -366,9 +378,5 @@ CLEANFILES = $(BUILT_SOURCES)
dist-hook:
cd $(distdir); rm -f $(BUILT_SOURCES)
+noinst_SCRIPTS = evolution-nognome
-if HAVE_DTAPPINTEGRATE
-
-bin_SCRIPTS = evolution-nognome
-
-endif