aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 878642ec21..877d4c83bc 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -27,10 +27,16 @@ AM_CPPFLAGS = \
$(TZDIALOG_CFLAGS) \
$(SHELL_CFLAGS)
+if NM_SUPPORT
+AM_CPPFLAGS += \
+ $(DBUS_GLIB_CFLAGS) \
+ $(NM_CFLAGS)
+endif
+
bin_PROGRAMS = evolution
if NM_SUPPORT
-NM_SUPPORT_FILES = e-shell-nm.c
+NM_SUPPORT_FILES = e-shell-nm.c
endif
# Data Server CORBA stuff
@@ -103,6 +109,10 @@ libeshell_la_LIBADD = \
$(top_builddir)/widgets/menus/libmenus.la \
$(SHELL_LIBS)
+if NM_SUPPORT
+libeshell_la_LIBADD += $(DBUS_GLIB_LIBS)
+endif
+
# Evolution executable
if HAVE_WINDRES