aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/tnef-attachments/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/tnef-attachments/Makefile.am')
-rw-r--r--plugins/tnef-attachments/Makefile.am16
1 files changed, 10 insertions, 6 deletions
diff --git a/plugins/tnef-attachments/Makefile.am b/plugins/tnef-attachments/Makefile.am
index 2273e6ed80..26a679b58a 100644
--- a/plugins/tnef-attachments/Makefile.am
+++ b/plugins/tnef-attachments/Makefile.am
@@ -6,7 +6,14 @@ NO_UNDEFINED_REQUIRED_LIBS = \
$(top_builddir)/mail/libevolution-mail.la
endif
-AM_CPPFLAGS = \
+@EVO_PLUGIN_RULE@
+
+plugin_DATA = org-gnome-tnef-attachments.eplug
+
+plugin_LTLIBRARIES = liborg-gnome-tnef-attachments.la
+
+liborg_gnome_tnef_attachments_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
-I$(top_srcdir) \
-I$(top_srcdir)/widgets \
-DGETTEXT_PACKAGE="\"$(GETTEXT_PACKAGE)\"" \
@@ -14,13 +21,10 @@ AM_CPPFLAGS = \
$(EVOLUTION_MAIL_CFLAGS) \
$(TNEF_CFLAGS)
-@EVO_PLUGIN_RULE@
-
-plugin_DATA = org-gnome-tnef-attachments.eplug
-plugin_LTLIBRARIES = liborg-gnome-tnef-attachments.la
-
liborg_gnome_tnef_attachments_la_SOURCES = tnef-plugin.c
+
liborg_gnome_tnef_attachments_la_LDFLAGS = -module -avoid-version $(NO_UNDEFINED)
+
liborg_gnome_tnef_attachments_la_LIBADD = \
$(top_builddir)/e-util/libeutil.la \
$(top_builddir)/em-format/libemformat.la \