aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/tnef-attachments/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/tnef-attachments/Makefile.am')
-rw-r--r--plugins/tnef-attachments/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/plugins/tnef-attachments/Makefile.am b/plugins/tnef-attachments/Makefile.am
index 7f52413306..809d1ed1f4 100644
--- a/plugins/tnef-attachments/Makefile.am
+++ b/plugins/tnef-attachments/Makefile.am
@@ -1,3 +1,11 @@
+if OS_WIN32
+NO_UNDEFINED_REQUIRED_LIBS = \
+ $(EVOLUTION_MAIL_LIBS) \
+ $(GNOME_PLATFORM_LIBS) \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/mail/libevolution-mail.la
+endif
+
INCLUDES = \
-I$(top_srcdir) \
-DGETTEXT_PACKAGE="\"$(GETTEXT_PACKAGE)\"" \
@@ -11,7 +19,10 @@ plugin_DATA = org-gnome-tnef-attachments.eplug
plugin_LTLIBRARIES = liborg-gnome-tnef-attachments.la
liborg_gnome_tnef_attachments_la_SOURCES = tnef-plugin.c
-liborg_gnome_tnef_attachments_la_LDFLAGS = -module -avoid-version -lytnef
+liborg_gnome_tnef_attachments_la_LDFLAGS = -module -avoid-version $(NO_UNDEFINED)
+liborg_gnome_tnef_attachments_la_LIBADD = \
+ $(NO_UNDEFINED_REQUIRED_LIBS) \
+ -lytnef
EXTRA_DIST = org-gnome-tnef-attachments.eplug.xml