aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/templates/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/templates/Makefile.am')
-rw-r--r--plugins/templates/Makefile.am27
1 files changed, 22 insertions, 5 deletions
diff --git a/plugins/templates/Makefile.am b/plugins/templates/Makefile.am
index f43dce0992..5a36917fa2 100644
--- a/plugins/templates/Makefile.am
+++ b/plugins/templates/Makefile.am
@@ -15,7 +15,11 @@ plugin_DATA = \
plugin_LTLIBRARIES = liborg-gnome-templates.la
liborg_gnome_templates_la_SOURCES = templates.c
-liborg_gnome_templates_la_LDFLAGS = -module -avoid-version
+liborg_gnome_templates_la_LDFLAGS = -module -avoid-version $(NO_UNDEFINED)
+liborg_gnome_templates_la_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/mail/libevolution-mail.la \
+ $(EVOLUTION_MAIL_LIBS)
schemadir = $(GCONF_SCHEMA_FILE_DIR)
schema_in_files = apps-evolution-template-placeholders.schemas.in
@@ -23,12 +27,25 @@ schema_DATA = $(schema_in_files:.schemas.in=.schemas)
@INTLTOOL_SCHEMAS_RULE@
+if OS_WIN32
install-data-local:
- if test -z "$(DESTDIR)" ; then \
- for p in $(schema_DATA) ; do \
- GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $$p; \
- done \
+ if test -z "$(DESTDIR)" ; then \
+ for p in $(schema_DATA) ; do \
+ (echo set GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE); \
+ echo $(GCONFTOOL) --makefile-install-rule $$p) >_temp.bat; \
+ cmd /c _temp.bat; \
+ rm _temp.bat; \
+ done \
fi
+else
+install-data-local:
+ if test -z "$(DESTDIR)" ; then \
+ for p in $(schema_DATA) ; do \
+ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) \
+ $(GCONFTOOL) --makefile-install-rule $$p; \
+ done \
+ fi
+endif
EXTRA_DIST = org-gnome-templates.eplug.xml \
$(schema_in_files) \