aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/save-attachments/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/save-attachments/Makefile.am')
-rw-r--r--plugins/save-attachments/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/plugins/save-attachments/Makefile.am b/plugins/save-attachments/Makefile.am
index e3ebc9f9e5..05c724a4e4 100644
--- a/plugins/save-attachments/Makefile.am
+++ b/plugins/save-attachments/Makefile.am
@@ -1,3 +1,11 @@
+if OS_WIN32
+NO_UNDEFINED_REQUIRED_LIBS = \
+ $(top_builddir)/mail/libevolution-mail.la \
+ $(EVOLUTION_MAIL_LIBS) \
+ $(GNOME_PLATFORM_LIBS) \
+ $(top_builddir)/e-util/libeutil.la
+endif
+
INCLUDES = \
-I$(top_srcdir) \
$(EVOLUTION_MAIL_CFLAGS)
@@ -8,7 +16,12 @@ plugin_DATA = org-gnome-save-attachments.eplug org-gnome-save-attachments.xml
plugin_LTLIBRARIES = liborg-gnome-save-attachments.la
liborg_gnome_save_attachments_la_SOURCES = save-attachments.c
-liborg_gnome_save_attachments_la_LDFLAGS = -module -avoid-version
+liborg_gnome_save_attachments_la_LDFLAGS = -module \
+ -avoid-version $(NO_UNDEFINED)
+
+liborg_gnome_save_attachments_la_LIBADD = \
+ $(NO_UNDEFINED_REQUIRED_LIBS)
+
EXTRA_DIST = \
org-gnome-save-attachments.eplug.xml \