aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/pst-import/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/pst-import/Makefile.am')
-rw-r--r--plugins/pst-import/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/plugins/pst-import/Makefile.am b/plugins/pst-import/Makefile.am
new file mode 100644
index 0000000000..031b1b181e
--- /dev/null
+++ b/plugins/pst-import/Makefile.am
@@ -0,0 +1,24 @@
+INCLUDES = \
+ -I$(EVOLUTION_SOURCE) \
+ -I$(top_srcdir) \
+ -DGETTEXT_PACKAGE="\"$(GETTEXT_PACKAGE)\"" \
+ -DLOCALEDIR="\"$(LOCALEDIR)\"" \
+ $(EVOLUTION_CFLAGS) \
+ $(EVOLUTION_MAIL_CFLAGS)
+
+@EVO_PLUGIN_RULE@
+
+plugin_DATA = org-gnome-pst-import.eplug
+plugin_LTLIBRARIES = liborg-gnome-pst-import.la
+
+liborg_gnome_pst_import_la_SOURCES = pst-importer.c
+liborg_gnome_pst_import_la_LDFLAGS = -module -avoid-version
+liborg_gnome_pst_import_la_LIBADD = \
+ $(LIBPST_LIBS)
+
+EXTRA_DIST = org-gnome-pst-import.eplug.xml
+
+BUILT_SOURCES = org-gnome-pst-import.eplug
+
+CLEANFILES = $(BUILT_SOURCES)
+