aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/pst-import/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/pst-import/Makefile.am')
-rw-r--r--plugins/pst-import/Makefile.am17
1 files changed, 14 insertions, 3 deletions
diff --git a/plugins/pst-import/Makefile.am b/plugins/pst-import/Makefile.am
index 031b1b181e..9f3061e241 100644
--- a/plugins/pst-import/Makefile.am
+++ b/plugins/pst-import/Makefile.am
@@ -1,10 +1,19 @@
+if OS_WIN32
+NO_UNDEFINED_REQUIRED_LIBS = \
+ $(top_builddir)/mail/libevolution-mail.la \
+ $(top_builddir)/e-util/libeutil.la \
+ $(EVOLUTION_CALENDAR_LIBS) \
+ $(EVOLUTION_MAIL_LIBS)
+endif
+
INCLUDES = \
-I$(EVOLUTION_SOURCE) \
-I$(top_srcdir) \
-DGETTEXT_PACKAGE="\"$(GETTEXT_PACKAGE)\"" \
-DLOCALEDIR="\"$(LOCALEDIR)\"" \
$(EVOLUTION_CFLAGS) \
- $(EVOLUTION_MAIL_CFLAGS)
+ $(EVOLUTION_MAIL_CFLAGS) \
+ $(LIBPST_CFLAGS)
@EVO_PLUGIN_RULE@
@@ -12,8 +21,10 @@ plugin_DATA = org-gnome-pst-import.eplug
plugin_LTLIBRARIES = liborg-gnome-pst-import.la
liborg_gnome_pst_import_la_SOURCES = pst-importer.c
-liborg_gnome_pst_import_la_LDFLAGS = -module -avoid-version
-liborg_gnome_pst_import_la_LIBADD = \
+liborg_gnome_pst_import_la_LDFLAGS = \
+ -module -avoid-version $(NO_UNDEFINED)
+liborg_gnome_pst_import_la_LIBADD = \
+ $(NO_UNDEFINED_REQUIRED_LIBS) \
$(LIBPST_LIBS)
EXTRA_DIST = org-gnome-pst-import.eplug.xml