aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/profiler/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/profiler/Makefile.am')
-rw-r--r--plugins/profiler/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/plugins/profiler/Makefile.am b/plugins/profiler/Makefile.am
index 21f63af33f..2a61fbafbe 100644
--- a/plugins/profiler/Makefile.am
+++ b/plugins/profiler/Makefile.am
@@ -1,15 +1,18 @@
-AM_CPPFLAGS = \
- -I$(top_srcdir) \
- $(SHELL_CFLAGS)
-
LIBS = $(SHELL_LIBS)
@EVO_PLUGIN_RULE@
plugin_DATA = org-gnome-evolution-profiler.eplug
+
plugin_LTLIBRARIES = liborg-gnome-evolution-profiler.la
+liborg_gnome_evolution_profiler_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -I$(top_srcdir) \
+ $(SHELL_CFLAGS)
+
liborg_gnome_evolution_profiler_la_SOURCES = profiler.c
+
liborg_gnome_evolution_profiler_la_LDFLAGS = -module -avoid-version $(NO_UNDEFINED)
EXTRA_DIST = org-gnome-evolution-profiler.eplug.xml