aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/mail-remote/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/mail-remote/Makefile.am')
-rw-r--r--plugins/mail-remote/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/plugins/mail-remote/Makefile.am b/plugins/mail-remote/Makefile.am
index ccdcae2348..8a43ea3473 100644
--- a/plugins/mail-remote/Makefile.am
+++ b/plugins/mail-remote/Makefile.am
@@ -23,6 +23,8 @@ liborg_gnome_evolution_mail_remote_la_SOURCES = \
evolution-mail-session.h \
evolution-mail-store.c \
evolution-mail-store.h \
+ evolution-mail-marshal.c \
+ evolution-mail-marshal.h \
mail-remote.c
liborg_gnome_evolution_mail_remote_la_LDFLAGS = -module -avoid-version
@@ -33,6 +35,7 @@ client_SOURCES = \
client_LDADD = \
$(EVOLUTION_MAIL_LIBS) \
evolution-mail-listener.o \
+ evolution-mail-marshal.o \
Evolution-DataServer-Mail-common.o \
Evolution-DataServer-Mail-stubs.o \
Evolution-DataServer-Mail-skels.o
@@ -59,8 +62,13 @@ $(IDL_GENERATED_H) $(IDL_GENERATED_C): $(IDL)
#idl_DATA = $(IDL)
+# marshallers for glib
+MARSHAL_GENERATED = evolution-mail-marshal.c evolution-mail-marshal.h
+@EVO_MARSHAL_RULE@
+
EXTRA_DIST = \
- $(IDL)
+ $(IDL) \
+ evolution-mail-marshal.list
-BUILT_SOURCES = $(IDL_GENERATED_H) $(IDL_GENERATED_C)
+BUILT_SOURCES = $(IDL_GENERATED_H) $(IDL_GENERATED_C) $(MARSHAL_GENERATED)
CLEANFILES = $(BUILT_SOURCES)