aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/mail-remote/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/mail-remote/Makefile.am')
-rw-r--r--plugins/mail-remote/Makefile.am44
1 files changed, 33 insertions, 11 deletions
diff --git a/plugins/mail-remote/Makefile.am b/plugins/mail-remote/Makefile.am
index 25653f666b..6f0601b541 100644
--- a/plugins/mail-remote/Makefile.am
+++ b/plugins/mail-remote/Makefile.am
@@ -1,4 +1,35 @@
+INCLUDES = \
+ -I$(top_srcdir) \
+ $(EVOLUTION_MAIL_CFLAGS)
+
+@EVO_PLUGIN_RULE@
+
+plugin_DATA = org-gnome-evolution-mail-remote.eplug
+plugin_LTLIBRARIES = liborg-gnome-evolution-mail-remote.la
+
+liborg_gnome_evolution_mail_remote_la_SOURCES = \
+ $(IDL_GENERATED_C) \
+ $(IDL_GENERATED_H) \
+ evolution-mail-folder.c \
+ evolution-mail-folder.h \
+ evolution-mail-session.c \
+ evolution-mail-session.h \
+ evolution-mail-store.c \
+ evolution-mail-store.h \
+ mail-remote.c
+
+liborg_gnome_evolution_mail_remote_la_LDFLAGS = -module -avoid-version
+
+client_SOURCES = \
+ client.c
+
+client_LDADD = \
+ $(EVOLUTION_MAIL_LIBS) \
+ liborg-gnome-evolution-mail-remote.la
+
+noinst_PROGRAMS = \
+ client
# mail idl
@@ -17,19 +48,10 @@ $(IDL_GENERATED_H) $(IDL_GENERATED_C): $(IDL)
# installed idls
-idl_DATA = $(IDL)
-
-_SOURCES = \
- $(IDL_GENERATED_C) \
- $(IDL_GENERATED_H) \
- evolution-mail-folder.c \
- evolution-mail-folder.h \
- evolution-mail-session.c \
- evolution-mail-session.h \
- evolution-mail-store.c \
- evolution-mail-store.h
+#idl_DATA = $(IDL)
EXTRA_DIST = \
$(IDL)
BUILT_SOURCES = $(IDL_GENERATED_H) $(IDL_GENERATED_C)
+CLEANFILES = $(BUILT_SOURCES)