aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/mail-notification/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/mail-notification/Makefile.am')
-rw-r--r--plugins/mail-notification/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/plugins/mail-notification/Makefile.am b/plugins/mail-notification/Makefile.am
index 80b4fbcc98..627fd93bed 100644
--- a/plugins/mail-notification/Makefile.am
+++ b/plugins/mail-notification/Makefile.am
@@ -1,3 +1,7 @@
+if OS_WIN32
+NO_UNDEFINED_REQUIRED_LIBS = $(GNOME_PLATFORM_LIBS)
+endif
+
INCLUDES = \
-I$(top_srcdir) \
$(EVOLUTION_MAIL_CFLAGS) \
@@ -16,8 +20,10 @@ plugin_LTLIBRARIES = liborg-gnome-mail-notification.la
liborg_gnome_mail_notification_la_SOURCES = mail-notification.c
liborg_gnome_mail_notification_la_LDFLAGS = \
- -module -avoid-version \
- $(LIBNOTIFY_LIBS)
+ -module -avoid-version $(NO_UNDEFINED)
+liborg_gnome_mail_notification_la_LIBADD = \
+ $(LIBNOTIFY_LIBS) \
+ $(NO_UNDEFINED_REQUIRED_LIBS)
if ENABLE_DBUS
liborg_gnome_mail_notification_la_LDFLAGS += $(NMN_LIBS)