aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/external-editor/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/external-editor/Makefile.am')
-rw-r--r--plugins/external-editor/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/plugins/external-editor/Makefile.am b/plugins/external-editor/Makefile.am
index 0c7c22ab8b..bae2c640a5 100644
--- a/plugins/external-editor/Makefile.am
+++ b/plugins/external-editor/Makefile.am
@@ -1,3 +1,11 @@
+if OS_WIN32
+NO_UNDEFINED_REQUIRED_LIBS = \
+ $(EVOLUTION_MAIL_LIBS) \
+ $(GNOME_PLATFORM_LIBS) \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/mail/libevolution-mail.la
+endif
+
INCLUDES = \
-DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
-DEVOLUTION_TOOLSDIR=\""$(privlibexecdir)"\" \
@@ -25,7 +33,10 @@ plugin_LTLIBRARIES = liborg-gnome-external-editor.la
liborg_gnome_external_editor_la_SOURCES = \
external-editor.c
-liborg_gnome_external_editor_la_LDFLAGS = -module -avoid-version
+liborg_gnome_external_editor_la_LDFLAGS = \
+ -module -avoid-version $(NO_UNDEFINED)
+liborg_gnome_external_editor_la_LIBADD = \
+ $(NO_UNDEFINED_REQUIRED_LIBS)
schemadir = $(GCONF_SCHEMA_FILE_DIR)
schema_in_files = apps-evolution-external-editor.schemas.in