aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/calendar-weather/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/calendar-weather/Makefile.am')
-rw-r--r--plugins/calendar-weather/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/plugins/calendar-weather/Makefile.am b/plugins/calendar-weather/Makefile.am
new file mode 100644
index 0000000000..ef17a5314b
--- /dev/null
+++ b/plugins/calendar-weather/Makefile.am
@@ -0,0 +1,29 @@
+INCLUDES = \
+ -I$(top_srcdir)/shell \
+ $(EVOLUTION_CFLAGS) \
+ $(EVOLUTION_CALENDAR_CFLAGS) \
+ $(SOURCE_SEL_CFLAGS) \
+ -DWEATHER_DATADIR=\""$(weatherdatadir)"\"
+
+@EVO_PLUGIN_RULE@
+
+# These will actually install into the e-d-s share directory, but
+# if the plugin is disabled, we aren't going to be needing them.
+weatherdata_DATA = \
+ category_weather_cloudy_16.png \
+ category_weather_fog_16.png \
+ category_weather_partly_cloudy_16.png \
+ category_weather_rain_16.png \
+ category_weather_snow_16.png \
+ category_weather_sun_16.png \
+ category_weather_tstorm_16.png
+
+plugin_DATA = org-gnome-calendar-weather.eplug
+plugin_LTLIBRARIES = liborg-gnome-calendar-weather.la
+
+liborg_gnome_calendar_weather_la_SOURCES = calendar-weather.c
+liborg_gnome_calendar_weather_la_LDFLAGS = -module -avoid-version
+
+EXTRA_DIST = \
+ org-gnome-calendar-weather.eplug.in \
+ $(weatherdata_DATA)