aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/calendar-weather/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/calendar-weather/Makefile.am')
-rw-r--r--plugins/calendar-weather/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/plugins/calendar-weather/Makefile.am b/plugins/calendar-weather/Makefile.am
index 8f57db1dcc..b5a811118c 100644
--- a/plugins/calendar-weather/Makefile.am
+++ b/plugins/calendar-weather/Makefile.am
@@ -1,5 +1,7 @@
eds_datadir = `pkg-config --variable=privdatadir evolution-data-server-1.2`
weatherdatadir = $(datadir)/evolution/$(BASE_VERSION)/weather
+LIBGWEATHER_CFLAGS = `pkg-config --cflags gweather`
+LIBGWEATHER_LIBS = `pkg-config --libs gweather`
INCLUDES = \
-I$(top_srcdir) \
@@ -7,7 +9,8 @@ INCLUDES = \
$(EVOLUTION_CALENDAR_CFLAGS) \
$(SOURCE_SEL_CFLAGS) \
-DWEATHER_DATADIR=\""$(weatherdatadir)"\" \
- -DWEATHER_EDS_DATADIR=\""$(eds_datadir)/weather"\"
+ -DWEATHER_EDS_DATADIR=\""$(eds_datadir)/weather"\" \
+ $(LIBGWEATHER_CFLAGS)
@EVO_PLUGIN_RULE@
@@ -24,12 +27,12 @@ plugin_DATA = org-gnome-calendar-weather.eplug
plugin_LTLIBRARIES = liborg-gnome-calendar-weather.la
liborg_gnome_calendar_weather_la_SOURCES = calendar-weather.c
-liborg_gnome_calendar_weather_la_LDFLAGS = -module -avoid-version $(NO_UNDEFINED)
-liborg_gnome_calendar_weather_la_LIBADD = \
+liborg_gnome_calendar_weather_la_LDFLAGS = -module -avoid-version $(NO_UNDEFINED) $(LIBGWEATHER_LIBS)
+liborg_gnome_calendar_weather_la_LIBADD = \
$(top_builddir)/calendar/gui/libevolution-calendar.la \
$(EVOLUTION_CALENDAR_LIBS)
-EXTRA_DIST = \
+EXTRA_DIST = \
org-gnome-calendar-weather.eplug.xml \
$(weatherdata_DATA)