aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/backup-restore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/backup-restore/Makefile.am')
-rw-r--r--plugins/backup-restore/Makefile.am37
1 files changed, 26 insertions, 11 deletions
diff --git a/plugins/backup-restore/Makefile.am b/plugins/backup-restore/Makefile.am
index b848d3c51b..9ffb2e340e 100644
--- a/plugins/backup-restore/Makefile.am
+++ b/plugins/backup-restore/Makefile.am
@@ -1,4 +1,13 @@
-AM_CPPFLAGS = \
+@EVO_PLUGIN_RULE@
+
+error_DATA = org-gnome-backup-restore.error
+errordir = $(privdatadir)/errors
+
+plugin_DATA = org-gnome-backup-restore.eplug
+plugin_LTLIBRARIES = liborg-gnome-backup-restore.la
+
+liborg_gnome_backup_restore_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
-I$(top_srcdir) \
-I$(top_srcdir)/widgets \
-DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
@@ -9,15 +18,7 @@ AM_CPPFLAGS = \
-DLIBDIR=\""$(libdir)"\" \
$(EVOLUTION_CALENDAR_CFLAGS) \
$(SHELL_CFLAGS) \
- $(E_UTIL_CFLAGS)
-
-@EVO_PLUGIN_RULE@
-
-error_DATA = org-gnome-backup-restore.error
-errordir = $(privdatadir)/errors
-
-plugin_DATA = org-gnome-backup-restore.eplug
-plugin_LTLIBRARIES = liborg-gnome-backup-restore.la
+ $(E_UTIL_CFLAGS)
liborg_gnome_backup_restore_la_SOURCES = backup-restore.c
liborg_gnome_backup_restore_la_LDFLAGS = -module -avoid-version $(NO_UNDEFINED)
@@ -28,6 +29,20 @@ liborg_gnome_backup_restore_la_LIBADD = \
privlibexec_PROGRAMS = evolution-backup
evolution_backup_SOURCES = backup.c
+evolution_backup_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/widgets \
+ -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
+ -DEVOLUTION_TOOLSDIR=\""$(privlibexecdir)"\" \
+ -DPREFIX=\""$(prefix)"\" \
+ -DSYSCONFDIR=\""$(sysconfdir)"\" \
+ -DDATADIR=\""$(datadir)"\" \
+ -DLIBDIR=\""$(libdir)"\" \
+ $(EVOLUTION_CALENDAR_CFLAGS) \
+ $(SHELL_CFLAGS) \
+ $(E_UTIL_CFLAGS)
+
evolution_backup_LDADD = \
$(SHELL_LIBS) \
$(top_builddir)/e-util/libeutil.la
@@ -36,13 +51,13 @@ if OS_WIN32
evolution_backup_LDFLAGS = -mwindows
endif
-
EXTRA_DIST = \
org-gnome-backup-restore.eplug.xml \
org-gnome-backup-restore.error.xml
BUILT_SOURCES = org-gnome-backup-restore.eplug \
org-gnome-backup-restore.error
+
CLEANFILES = $(BUILT_SOURCES)
-include $(top_srcdir)/git.mk