aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/backup-restore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/backup-restore/Makefile.am')
-rw-r--r--plugins/backup-restore/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/plugins/backup-restore/Makefile.am b/plugins/backup-restore/Makefile.am
new file mode 100644
index 0000000000..3627d1c69a
--- /dev/null
+++ b/plugins/backup-restore/Makefile.am
@@ -0,0 +1,26 @@
+INCLUDES = \
+ -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
+ -DEVOLUTION_TOOLSDIR=\""$(privlibexecdir)"\" \
+ -DPREFIX=\""$(prefix)"\" \
+ -DSYSCONFDIR=\""$(sysconfdir)"\" \
+ -DDATADIR=\""$(datadir)"\" \
+ -DLIBDIR=\""$(libdir)"\" \
+ -I$(top_srcdir) \
+ $(SHELL_CFLAGS) \
+ $(E_UTIL_CFLAGS)
+
+@EVO_PLUGIN_RULE@
+
+plugin_DATA = org-gnome-backup-restore.eplug org-gnome-backup-restore.xml
+plugin_LTLIBRARIES = liborg-gnome-backup-restore.la
+
+liborg_gnome_backup_restore_la_SOURCES = backup-restore.c
+liborg_gnome_backup_restore_la_LDFLAGS = -module -avoid-version
+
+privlibexec_PROGRAMS = backup
+backup_SOURCES = backup.c
+backup_LDADD = $(SHELL_LIBS)
+
+EXTRA_DIST = \
+ org-gnome-backup-restore.eplug.in \
+ org-gnome-backup-restore.xml \ No newline at end of file