aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/attachment-reminder/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/attachment-reminder/Makefile.am')
-rw-r--r--plugins/attachment-reminder/Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/plugins/attachment-reminder/Makefile.am b/plugins/attachment-reminder/Makefile.am
index 78c2ae8f79..3a4c8b62ac 100644
--- a/plugins/attachment-reminder/Makefile.am
+++ b/plugins/attachment-reminder/Makefile.am
@@ -4,15 +4,14 @@ INCLUDES = \
$(EVOLUTION_MAIL_CFLAGS) \
-DEVOLUTION_PLUGINDIR="\"$(plugindir)\""
+@EVO_PLUGIN_RULE@
+
error_DATA = \
- org-gnome-attachment-reminder.errors.xml
+ org-gnome-attachment-reminder.error
errordir = $(privdatadir)/errors
-
-@EVO_PLUGIN_RULE@
-
plugin_DATA = \
org-gnome-evolution-attachment-reminder.eplug \
attachment-reminder.glade
@@ -39,10 +38,13 @@ install-data-local:
fi
EXTRA_DIST = org-gnome-evolution-attachment-reminder.eplug.xml \
- $(error_DATA) \
+ org-gnome-attachment-reminder.error.xml \
$(schema_in_files) \
attachment-reminder.glade
-CLEANFILES = org-gnome-evolution-attachment-reminder.eplug
+BUILT_SOURCES = org-gnome-evolution-attachment-reminder.eplug \
+ org-gnome-attachment-reminder.error
+
+CLEANFILES = $(BUILT_SOURCES)
DISTCLEANFILES = $(schema_DATA)