aboutsummaryrefslogtreecommitdiffstats
path: root/omf-install/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'omf-install/Makefile.am')
-rw-r--r--omf-install/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/omf-install/Makefile.am b/omf-install/Makefile.am
new file mode 100644
index 0000000000..ee542a8598
--- /dev/null
+++ b/omf-install/Makefile.am
@@ -0,0 +1,17 @@
+omf_dest_dir=$(datadir)/omf/evolution
+scrollkeeper_localstate_dir = $(localstatedir)/scrollkeeper
+
+install-data-local:
+ $(mkinstalldirs) $(DESTDIR)$(omf_dest_dir)
+ -for file in $(srcdir)/*.omf; do \
+ $(INSTALL_DATA) $(srcdir)/$$file $(DESTDIR)$(omf_dest_dir); \
+ done
+ -scrollkeeper-update -p $(scrollkeeper_localstate_dir)
+
+uninstall-local:
+ -for file in $(srcdir)/*.omf; do \
+ basefile=`basename $$file`; \
+ rm -f $(omf_dest_dir)/$$basefile; \
+ done
+ -rmdir $(omf_dest_dir)
+ -scrollkeeper-update -p $(scrollkeeper_localstate_dir)