aboutsummaryrefslogtreecommitdiffstats
path: root/notes/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'notes/Makefile.am')
-rw-r--r--notes/Makefile.am18
1 files changed, 3 insertions, 15 deletions
diff --git a/notes/Makefile.am b/notes/Makefile.am
index c24c2590ce..388e19152a 100644
--- a/notes/Makefile.am
+++ b/notes/Makefile.am
@@ -14,14 +14,6 @@ INCLUDES = \
-DEVOLUTION_DATADIR=\""$(datadir)"\" \
-DG_LOG_DOMAIN=\"evolution-notes\"
-# FIXME We should make a libeshell library instead of this gross hack.
-SHELL_OBJS = \
- $(top_builddir)/shell/Evolution-common.o \
- $(top_builddir)/shell/Evolution-stubs.o \
- $(top_builddir)/shell/Evolution-skels.o \
- $(top_builddir)/shell/evolution-shell-component.o \
- $(top_builddir)/shell/evolution-storage.o
-
evolution_notes_SOURCES = \
component-factory.c \
main.c \
@@ -45,14 +37,10 @@ endif
notes_test_LDADD = \
$(top_builddir)/widgets/e-text/libetext.a \
- ../e-util/libeutil.la \
+ $(top_builddir)/e-util/libeutil.la \
$(BONOBO_HTML_GNOME_LIBS)
evolution_notes_LDADD = \
- ../e-util/libeutil.la \
- $(SHELL_OBJS) \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/shell/libeshell.a \
$(BONOBO_HTML_GNOME_LIBS)
-
-
-
-