aboutsummaryrefslogtreecommitdiffstats
path: root/my-evolution/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'my-evolution/Makefile.am')
-rw-r--r--my-evolution/Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/my-evolution/Makefile.am b/my-evolution/Makefile.am
index 0cb6e8ca02..e86b7c9e5f 100644
--- a/my-evolution/Makefile.am
+++ b/my-evolution/Makefile.am
@@ -18,17 +18,20 @@ INCLUDES = \
IDLS = \
$(top_srcdir)/mail/Mailer.idl
-MAIL_GENERATED = \
- Mailer.h \
+IDL_GENERATED_H = \
+ Mailer.h
+IDL_GENERATED_C = \
Mailer-common.c \
Mailer-skels.c \
Mailer-stubs.c
+IDL_GENERATED = $(IDL_GENERATED_C) $(IDL_GENERATED_H)
-$(MAIL_GENERATED): $(IDLS)
+$(IDL_GENERATED_H): $(IDLS)
$(ORBIT_IDL) -I $(srcdir) $(IDL_INCLUDES) $(top_srcdir)/mail/Mailer.idl
+$(IDL_GENERATED_C): $(IDL_GENERATED_H)
summary_sources = \
- $(MAIL_GENERATED) \
+ $(IDL_GENERATED) \
component-factory.c \
component-factory.h \
e-cell-tri.c \
@@ -123,5 +126,8 @@ EXTRA_DIST = \
check-filled.xpm \
check-none.xpm
+BUILT_SOURCES = $(IDL_GENERATED)
+CLEANFILES = $(BUILT_SOURCES)
+
dist-hook:
cd $(distdir); rm -f $(BUILT_SOURCES)