aboutsummaryrefslogtreecommitdiffstats
path: root/modules/tnef-attachment/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/tnef-attachment/Makefile.am')
-rw-r--r--modules/tnef-attachment/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/modules/tnef-attachment/Makefile.am b/modules/tnef-attachment/Makefile.am
new file mode 100644
index 0000000000..ff5b412275
--- /dev/null
+++ b/modules/tnef-attachment/Makefile.am
@@ -0,0 +1,34 @@
+if OS_WIN32
+NO_UNDEFINED_REQUIRED_LIBS = \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/mail/libevolution-mail.la
+endif
+
+module_LTLIBRARIES = module-tnef-attachment.la
+
+module_tnef_attachment_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/widgets \
+ -DEVOLUTION_PRIVDATADIR=\""$(privdatadir)"\" \
+ -DG_LOG_DOMAIN=\"evolution-module-tnef-attachment\" \
+ $(EVOLUTION_DATA_SERVER_CFLAGS) \
+ $(GNOME_PLATFORM_CFLAGS) \
+ $(TNEF_CFLAGS)
+
+module_tnef_attachment_la_SOURCES = \
+ e-mail-parser-tnef-attachment.c \
+ e-mail-parser-tnef-attachment.h \
+ evolution-module-tnef-attachment.c
+
+module_tnef_attachment_la_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/em-format/libemformat.la \
+ $(EVOLUTION_DATA_SERVER_LIBS) \
+ $(GNOME_PLATFORM_LIBS) \
+ -lytnef
+
+module_tnef_attachment_la_LDFLAGS = \
+ -avoid-version -module $(NO_UNDEFINED)
+
+-include $(top_srcdir)/git.mk