aboutsummaryrefslogtreecommitdiffstats
path: root/modules/prefer-plain/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/prefer-plain/Makefile.am')
-rw-r--r--modules/prefer-plain/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/modules/prefer-plain/Makefile.am b/modules/prefer-plain/Makefile.am
index ac471dfcbd..1b0289ec9e 100644
--- a/modules/prefer-plain/Makefile.am
+++ b/modules/prefer-plain/Makefile.am
@@ -5,11 +5,12 @@ module_LTLIBRARIES = module-prefer-plain.la
module_prefer_plain_la_CPPFLAGS = \
$(AM_CPPFLAGS) \
-I$(top_srcdir) \
- -I$(top_srcdir)/widgets \
-DEVOLUTION_PRIVDATADIR=\""$(privdatadir)"\" \
-DG_LOG_DOMAIN=\"evolution-module-prefer-plain\" \
$(EVOLUTION_DATA_SERVER_CFLAGS) \
- $(GNOME_PLATFORM_CFLAGS)
+ $(GNOME_PLATFORM_CFLAGS) \
+ $(CHAMPLAIN_CFLAGS) \
+ $(GTKHTML_CFLAGS)
module_prefer_plain_la_SOURCES = \
e-mail-parser-prefer-plain.c \
@@ -19,12 +20,14 @@ module_prefer_plain_la_SOURCES = \
evolution-module-prefer-plain.c
module_prefer_plain_la_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la \
$(top_builddir)/mail/libevolution-mail.la \
$(top_builddir)/em-format/libemformat.la \
$(top_builddir)/shell/libeshell.la \
- $(top_builddir)/widgets/misc/libemiscwidgets.la \
$(EVOLUTION_DATA_SERVER_LIBS) \
- $(GNOME_PLATFORM_LIBS)
+ $(GNOME_PLATFORM_LIBS) \
+ $(CHAMPLAIN_LIBS) \
+ $(GTKHTML_LIBS)
module_prefer_plain_la_LDFLAGS = \
-avoid-version -module $(NO_UNDEFINED)