aboutsummaryrefslogtreecommitdiffstats
path: root/modules/prefer-plain/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/prefer-plain/Makefile.am')
-rw-r--r--modules/prefer-plain/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/modules/prefer-plain/Makefile.am b/modules/prefer-plain/Makefile.am
new file mode 100644
index 0000000000..e4e6b56d02
--- /dev/null
+++ b/modules/prefer-plain/Makefile.am
@@ -0,0 +1,28 @@
+SUBDIRS=plugin
+
+module_LTLIBRARIES = module-prefer-plain.la
+
+module_prefer_plain_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/widgets \
+ -DEVOLUTION_PRIVDATADIR=\""$(privdatadir)"\" \
+ -DG_LOG_DOMAIN=\"evolution-module-prefer-plain\" \
+ $(EVOLUTION_DATA_SERVER_CFLAGS) \
+ $(GNOME_PLATFORM_CFLAGS)
+
+module_prefer_plain_la_SOURCES = \
+ e-mail-parser-prefer-plain.c \
+ e-mail-parser-prefer-plain.h \
+ evolution-module-prefer-plain.c
+
+module_prefer_plain_la_LIBADD = \
+ $(top_builddir)/mail/libevolution-mail.la \
+ $(top_builddir)/em-format/libemformat.la \
+ $(EVOLUTION_DATA_SERVER_LIBS) \
+ $(GNOME_PLATFORM_LIBS)
+
+module_prefer_plain_la_LDFLAGS = \
+ -avoid-version -module $(NO_UNDEFINED)
+
+-include $(top_srcdir)/git.mk