aboutsummaryrefslogtreecommitdiffstats
path: root/modules/plugin-manager/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/plugin-manager/Makefile.am')
-rw-r--r--modules/plugin-manager/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/modules/plugin-manager/Makefile.am b/modules/plugin-manager/Makefile.am
index 03eaa3d77a..0c6a38aab5 100644
--- a/modules/plugin-manager/Makefile.am
+++ b/modules/plugin-manager/Makefile.am
@@ -3,10 +3,11 @@ module_LTLIBRARIES = module-plugin-manager.la
module_plugin_manager_la_CPPFLAGS = \
$(AM_CPPFLAGS) \
-I$(top_srcdir) \
- -I$(top_srcdir)/widgets \
-DG_LOG_DOMAIN=\"evolution-plugin-manager\" \
$(EVOLUTION_DATA_SERVER_CFLAGS) \
- $(GNOME_PLATFORM_CFLAGS)
+ $(GNOME_PLATFORM_CFLAGS) \
+ $(CHAMPLAIN_CFLAGS) \
+ $(GTKHTML_CFLAGS)
module_plugin_manager_la_SOURCES = \
evolution-plugin-manager.c
@@ -15,7 +16,9 @@ module_plugin_manager_la_LIBADD = \
$(top_builddir)/e-util/libeutil.la \
$(top_builddir)/shell/libeshell.la \
$(EVOLUTION_DATA_SERVER_LIBS) \
- $(GNOME_PLATFORM_LIBS)
+ $(GNOME_PLATFORM_LIBS) \
+ $(CHAMPLAIN_LIBS) \
+ $(GTKHTML_LIBS)
module_plugin_manager_la_LDFLAGS = \
-module -avoid-version $(NO_UNDEFINED)