aboutsummaryrefslogtreecommitdiffstats
path: root/modules/contact-photos/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/contact-photos/Makefile.am')
-rw-r--r--modules/contact-photos/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/modules/contact-photos/Makefile.am b/modules/contact-photos/Makefile.am
new file mode 100644
index 0000000000..83b934471f
--- /dev/null
+++ b/modules/contact-photos/Makefile.am
@@ -0,0 +1,30 @@
+module_LTLIBRARIES = module-contact-photos.la
+
+module_contact_photos_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -I$(top_srcdir) \
+ -DG_LOG_DOMAIN=\"evolution-contact-photos\" \
+ $(EVOLUTION_DATA_SERVER_CFLAGS) \
+ $(GNOME_PLATFORM_CFLAGS) \
+ $(GTKHTML_CFLAGS) \
+ $(NULL)
+
+module_contact_photos_la_SOURCES = \
+ evolution-contact-photos.c \
+ e-contact-photo-source.c \
+ e-contact-photo-source.h \
+ e-photo-cache-contact-loader.c \
+ e-photo-cache-contact-loader.h \
+ $(NULL)
+
+module_contact_photos_la_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la \
+ $(EVOLUTION_DATA_SERVER_LIBS) \
+ $(GNOME_PLATFORM_LIBS) \
+ $(GTKHTML_LIBS) \
+ $(NULL)
+
+module_contact_photos_la_LDFLAGS = \
+ -module -avoid-version $(NO_UNDEFINED)
+
+-include $(top_srcdir)/git.mk