aboutsummaryrefslogtreecommitdiffstats
path: root/modules/connman/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/connman/Makefile.am')
-rw-r--r--modules/connman/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/modules/connman/Makefile.am b/modules/connman/Makefile.am
new file mode 100644
index 0000000000..63822262c4
--- /dev/null
+++ b/modules/connman/Makefile.am
@@ -0,0 +1,22 @@
+module_LTLIBRARIES = libevolution-module-connman.la
+
+libevolution_module_connman_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -I$(top_srcdir) \
+ -DG_LOG_DOMAIN=\"evolution-connman\" \
+ $(GNOME_PLATFORM_CFLAGS) \
+ $(DBUS_GLIB_CFLAGS)
+
+libevolution_module_connman_la_SOURCES = \
+ evolution-connman.c
+
+libevolution_module_connman_la_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/shell/libeshell.la \
+ $(GNOME_PLATFORM_LIBS) \
+ $(DBUS_GLIB_LIBS)
+
+libevolution_module_connman_la_LDFLAGS = \
+ -module -avoid-version $(NO_UNDEFINED)
+
+-include $(top_srcdir)/git.mk