aboutsummaryrefslogtreecommitdiffstats
path: root/filter/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'filter/Makefile.am')
-rw-r--r--filter/Makefile.am12
1 files changed, 1 insertions, 11 deletions
diff --git a/filter/Makefile.am b/filter/Makefile.am
index 2b4b1038d5..29fb45e32c 100644
--- a/filter/Makefile.am
+++ b/filter/Makefile.am
@@ -87,15 +87,5 @@ libfilter-i18n.h: filtertypes.xml vfoldertypes.xml
sed -n -e 's:.*<title>\(.*\)</title>:char *s = N_("\1");:p' | \
sort -u >> $@
-filter-marshal.h: filter-marshal.list
- ( @GLIB_GENMARSHAL@ --prefix=filter_marshal filter-marshal.list --header > filter-marshal.tmp \
- && mv filter-marshal.tmp filter-marshal.h ) \
- || ( rm -f filter-marshal.tmp && exit 1 )
-
-filter-marshal.c: filter-marshal.h
- ( @GLIB_GENMARSHAL@ --prefix=filter_marshal filter-marshal.list --body > filter-marshal.tmp \
- && mv filter-marshal.tmp filter-marshal.c ) \
- || ( rm -f filter-marshal.tmp && exit 1 )
-
MARSHAL_GENERATED = filter-marshal.c filter-marshal.h
-
+@EVO_MARSHAL_RULE@