aboutsummaryrefslogtreecommitdiffstats
path: root/executive-summary/idl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'executive-summary/idl/Makefile.am')
-rw-r--r--executive-summary/idl/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/executive-summary/idl/Makefile.am b/executive-summary/idl/Makefile.am
new file mode 100644
index 0000000000..84cca5934d
--- /dev/null
+++ b/executive-summary/idl/Makefile.am
@@ -0,0 +1,31 @@
+INCLUDES = \
+ -I$(top_srcdir)/widgets \
+ -I$(top_srcdir)/widgets/e-text \
+ -I$(top_srcdir) \
+ -I$(top_builddir)/shell \
+ -I$(top_srcdir)/shell \
+ $(GNOME_VFS_CFLAGS) \
+ $(UNICODE_CFLAGS) \
+ $(GTKHTML_CFLAGS) \
+ -DEVOLUTION_VERSION=\""$(VERSION)"\" \
+ -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
+ -DEVOLUTION_ICONSDIR=\""$(iconsdir)"\" \
+ -DEVOLUTION_LOCALEDIR=\""$(datadir)/locale"\" \
+ -DEVOLUTION_DATADIR=\""$(datadir)"\" \
+ -DG_LOG_DOMAIN=\"evolution-executive-summary\"
+
+EXTRA_DIST = $(IDLS)
+
+CLEANFILES = $(IDL_GENERATED)
+
+IDLS = \
+ Executive-Summary.idl \
+ Summary.idl \
+ SummaryComponent.idl
+
+IDL_GENERATED = \
+ Executive-Summary.h \
+ Executive-Summary-common.c \
+ Executive-Summary-skels.c \
+ Executive-Summary-stubs.c
+