aboutsummaryrefslogtreecommitdiffstats
path: root/executive-summary/evolution-services/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'executive-summary/evolution-services/Makefile.am')
-rw-r--r--executive-summary/evolution-services/Makefile.am58
1 files changed, 58 insertions, 0 deletions
diff --git a/executive-summary/evolution-services/Makefile.am b/executive-summary/evolution-services/Makefile.am
new file mode 100644
index 0000000000..8373dc72ab
--- /dev/null
+++ b/executive-summary/evolution-services/Makefile.am
@@ -0,0 +1,58 @@
+lib_LTLIBRARIES = libevolution-services.la
+
+INCLUDES = \
+ -I$(top_srcdir)/widgets \
+ -I$(top_srcdir)/widgets/e-text \
+ -I$(top_srcdir) \
+ -I$(top_builddir)/shell \
+ -I$(top_srcdir)/shell \
+ $(GNOME_VFS_CFLAGS) \
+ $(UNICODE_CFLAGS) \
+ $(GTKHTML_CFLAGS) \
+ -DEVOLUTION_VERSION=\""$(VERSION)"\" \
+ -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
+ -DEVOLUTION_ICONSDIR=\""$(iconsdir)"\" \
+ -DEVOLUTION_LOCALEDIR=\""$(datadir)/locale"\" \
+ -DEVOLUTION_DATADIR=\""$(datadir)"\" \
+ -DG_LOG_DOMAIN=\"evolution-services\"
+
+IDL_GENERATED = \
+ Executive-Summary.h \
+ Executive-Summary-common.c \
+ Executive-Summary-skels.c \
+ Executive-Summary-stubs.c
+
+Executive-Summary-impl.o: Executive-Summary.h
+
+$(IDL_GENERATED): $(IDLS)
+ $(ORBIT_IDL) -I $(datadir)/idl `$(GNOME_CONFIG) --cflags idl` \
+ -I$(srcdir) $(srcdir)/../idl/Executive-Summary.idl
+
+libevolution_services_la_SOURCES = \
+ $(IDL_GENERATED) \
+ executive-summary.c \
+ executive-summary.h \
+ executive-summary-client.c \
+ executive-summary-client.h \
+ executive-summary-component.c \
+ executive-summary-component.h \
+ executive-summary-component-client.c \
+ executive-summary-component-client.h
+
+libevolution_services_la_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la \
+ $(BONOBO_VFS_GNOME_LIBS) \
+ $(EXTRA_GNOME_LIBS) \
+ $(GTKHTML_LIBS) \
+ $(UNICODE_LIBS)
+
+if ENABLE_PURIFY
+PLINK = $(LIBTOOL) --mode=link $(PURIFY) $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) -o $@
+
+all-local: evolution-mail.pure
+
+evolution-mail.pure: evolution-mail
+ @rm -f evolution-mail.pure
+ $(PLINK) $(evolution_mail_LDFLAGS) $(evolution_mail_OBJECTS) $(evolution_mail_LDADD) $(LIBS)
+
+endif