aboutsummaryrefslogtreecommitdiffstats
path: root/executive-summary/component/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'executive-summary/component/Makefile.am')
-rw-r--r--executive-summary/component/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/executive-summary/component/Makefile.am b/executive-summary/component/Makefile.am
index c9931b19c0..1af1dd7df1 100644
--- a/executive-summary/component/Makefile.am
+++ b/executive-summary/component/Makefile.am
@@ -21,8 +21,6 @@ INCLUDES = \
-DEVOLUTION_DATADIR=\""$(datadir)"\" \
-DG_LOG_DOMAIN=\"evolution-executive-summary\"
-CLEANFILES = $(COMPOSER_GENERATED)
-
COMPOSER_GENERATED = \
Composer.h \
Composer-common.c \
@@ -86,3 +84,8 @@ evolution-executive-summary.pure: evolution-executive-summary
endif
EXTRA_DIST = $(glade_DATA)
+CLEANFILES += $(COMPOSER_GENERATED)
+BUILT_SOURCES = $(COMPOSER_GENERATED)
+
+dist-hook:
+ cd $(distdir); rm -f $(BUILT_SOURCES)