aboutsummaryrefslogtreecommitdiffstats
path: root/e-util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'e-util/Makefile.am')
-rw-r--r--e-util/Makefile.am22
1 files changed, 20 insertions, 2 deletions
diff --git a/e-util/Makefile.am b/e-util/Makefile.am
index 25e2d6a5a6..6f7923d86d 100644
--- a/e-util/Makefile.am
+++ b/e-util/Makefile.am
@@ -1,11 +1,17 @@
eutilincludedir = $(privincludedir)/e-util
econdincludedir = $(privincludedir)/e-conduit
+if ENABLE_MONO
+MONOHEADERS = e-plugin-mono.h
+MONOSOURCES = e-plugin-mono.c
+endif
+
INCLUDES = \
-I$(top_srcdir) \
-DEVOLUTION_IMAGES=\""$(imagesdir)"\" \
-DEVOLUTION_ICONSDIR=\""$(imagesdir)"\" \
-DEVOLUTION_CATEGORY_ICONS=\""$(imagesdir)/categories"\" \
+ -DEVOLUTION_PLUGINDIR=\""$(plugindir)"\" \
-DG_LOG_DOMAIN=\"e-utils\" \
$(GNOME_PILOT_CFLAGS) \
$(E_UTIL_CFLAGS)
@@ -19,10 +25,12 @@ eutilinclude_HEADERS = \
e-categories-config.h \
e-categories-master-list-wombat.h \
e-component-listener.h \
+ e-config.h \
e-config-listener.h \
e-corba-utils.h \
e-dialog-utils.h \
e-dialog-widgets.h \
+ e-event.h \
e-folder-map.h \
e-fsutils.h \
e-gtk-utils.h \
@@ -34,10 +42,13 @@ eutilinclude_HEADERS = \
e-list-iterator.h \
e-list.h \
e-memory.h \
+ e-menu.h \
e-mktemp.h \
e-msgport.h \
e-passwords.h \
e-path.h \
+ e-plugin.h \
+ e-popup.h \
e-request.h \
e-sexp.h \
e-signature.h \
@@ -46,7 +57,8 @@ eutilinclude_HEADERS = \
e-trie.h \
e-uid.h \
e-url.h \
- md5-utils.h
+ md5-utils.h \
+ $(MONOHEADERS)
libeutil_la_SOURCES = \
$(MARSHAL_GENERATED) \
@@ -57,10 +69,12 @@ libeutil_la_SOURCES = \
e-categories-config.c \
e-categories-master-list-wombat.c \
e-component-listener.c \
+ e-config.c \
e-config-listener.c \
e-corba-utils.c \
e-dialog-utils.c \
e-dialog-widgets.c \
+ e-event.c \
e-folder-map.c \
e-fsutils.c \
e-gtk-utils.c \
@@ -72,10 +86,13 @@ libeutil_la_SOURCES = \
e-list-iterator.c \
e-list.c \
e-memory.c \
+ e-menu.c \
e-mktemp.c \
e-msgport.c \
e-passwords.c \
e-path.c \
+ e-plugin.c \
+ e-popup.c \
e-request.c \
e-sexp.c \
e-signature.c \
@@ -86,7 +103,8 @@ libeutil_la_SOURCES = \
e-url.c \
eggtrayicon.c \
eggtrayicon.h \
- md5-utils.c
+ md5-utils.c \
+ $(MONOSOURCES)
MARSHAL_GENERATED = e-util-marshal.c e-util-marshal.h
@EVO_MARSHAL_RULE@