aboutsummaryrefslogtreecommitdiffstats
path: root/data/icons/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/icons/Makefile.am')
-rw-r--r--data/icons/Makefile.am83
1 files changed, 83 insertions, 0 deletions
diff --git a/data/icons/Makefile.am b/data/icons/Makefile.am
index 54b5f4bbf4..c6d2ba0d76 100644
--- a/data/icons/Makefile.am
+++ b/data/icons/Makefile.am
@@ -84,6 +84,71 @@ private_icons = \
hicolor_status_32x32_online.png \
$(NULL)
+# These icons were in gnome-icon-theme prior to GNOME 2.30.
+# XXX Need to reevaluate which icons we really need and drop the rest.
+# Many are not Tango-compliant and look dated and out of place.
+stock_private_icons = \
+ gnome_stock_data_16x16_stock_signature-bad.png \
+ gnome_stock_data_16x16_stock_signature-ok.png \
+ gnome_stock_data_16x16_stock_signature.png \
+ gnome_stock_data_24x24_stock_signature-bad.png \
+ gnome_stock_data_24x24_stock_signature-ok.png \
+ gnome_stock_data_24x24_stock_signature.png \
+ gnome_stock_data_48x48_stock_signature-bad.png \
+ gnome_stock_data_48x48_stock_signature-ok.png \
+ gnome_stock_data_48x48_stock_signature.png \
+ gnome_stock_document_16x16_stock_task-assigned.png \
+ gnome_stock_document_16x16_stock_task-assigned-to.png \
+ gnome_stock_document_16x16_stock_task.png \
+ gnome_stock_document_16x16_stock_task-recurring.png \
+ gnome_stock_document_16x16_stock_todo.png \
+ gnome_stock_document_24x24_stock_task-assigned.png \
+ gnome_stock_document_24x24_stock_task-assigned-to.png \
+ gnome_stock_document_24x24_stock_task.png \
+ gnome_stock_document_24x24_stock_task-recurring.png \
+ gnome_stock_document_24x24_stock_todo.png \
+ gnome_stock_document_48x48_stock_todo.png \
+ gnome_stock_generic_16x16_stock_bell.png \
+ gnome_stock_generic_16x16_stock_check-filled.png \
+ gnome_stock_generic_16x16_stock_new-meeting.png \
+ gnome_stock_generic_16x16_stock_score-higher.png \
+ gnome_stock_generic_16x16_stock_score-highest.png \
+ gnome_stock_generic_16x16_stock_score-high.png \
+ gnome_stock_generic_16x16_stock_score-lower.png \
+ gnome_stock_generic_16x16_stock_score-lowest.png \
+ gnome_stock_generic_16x16_stock_score-low.png \
+ gnome_stock_generic_16x16_stock_score-normal.png \
+ gnome_stock_generic_16x16_stock_show-all.png \
+ gnome_stock_generic_16x16_stock_timezone.png \
+ gnome_stock_generic_16x16_stock_view-details.png \
+ gnome_stock_generic_24x24_stock_new-meeting.png \
+ gnome_stock_generic_24x24_stock_show-all.png \
+ gnome_stock_generic_24x24_stock_timezone.png \
+ gnome_stock_generic_48x48_stock_alarm.png \
+ gnome_stock_generic_48x48_stock_new-meeting.png \
+ gnome_stock_generic_48x48_stock_timezone.png \
+ gnome_stock_net_16x16_stock_contact-list.png \
+ gnome_stock_net_16x16_stock_mail-filters-apply.png \
+ gnome_stock_net_16x16_stock_mail-flag-for-followup-done.png \
+ gnome_stock_net_16x16_stock_mail-flag-for-followup.png \
+ gnome_stock_net_16x16_stock_mail-open-multiple.png \
+ gnome_stock_net_16x16_stock_mail-unread-multiple.png \
+ gnome_stock_net_16x16_stock_shared-by-me.png \
+ gnome_stock_net_16x16_stock_shared-to-me.png \
+ gnome_stock_net_16x16_stock_video-conferencing.png \
+ gnome_stock_net_24x24_stock_contact-list.png \
+ gnome_stock_net_24x24_stock_mail-filters-apply.png \
+ gnome_stock_net_24x24_stock_mail-open-multiple.png \
+ gnome_stock_net_24x24_stock_mail-unread-multiple.png \
+ gnome_stock_net_24x24_stock_shared-by-me.png \
+ gnome_stock_net_24x24_stock_shared-to-me.png \
+ gnome_stock_net_24x24_stock_video-conferencing.png \
+ gnome_stock_net_48x48_stock_mail-flag-for-followup-done.png \
+ gnome_stock_net_48x48_stock_mail-flag-for-followup.png \
+ gnome_stock_object_16x16_stock_insert-note.png \
+ gnome_stock_object_24x24_stock_insert-note.png \
+ $(NULL)
+
# hicolor_status_16x16_wrapped.png was copied from Firefox
# (toolkit/themes/gnomestripe/global/icons/wrap.png), which
# contained the following notice:
@@ -124,6 +189,7 @@ noinst_DATA = \
EXTRA_DIST = \
$(public_icons) \
$(private_icons) \
+ $(stock_private_icons) \
$(noinst_DATA) \
$(NULL)
@@ -157,6 +223,15 @@ install-icons:
mkdir -p $(DESTDIR)$(pkgdatadir)/$(BASE_VERSION)/icons/$$THEME/$$SIZE/$$CONTEXT; \
$(INSTALL_DATA) $(srcdir)/$$icon $(DESTDIR)$(pkgdatadir)/$(BASE_VERSION)/icons/$$THEME/$$SIZE/$$CONTEXT/$$ICONFILE; \
done
+ for icon in $(stock_private_icons); do \
+ THEME=`echo $$icon | cut -d_ -f1`; \
+ STOCK=`echo $$icon | cut -d_ -f2`; \
+ CONTEXT=`echo $$icon | cut -d_ -f3`; \
+ SIZE=`echo $$icon | cut -d_ -f4`; \
+ ICONFILE=`echo $$icon | cut -d_ -f6`; \
+ mkdir -p $(DESTDIR)$(pkgdatadir)/$(BASE_VERSION)/icons/$$THEME/$$SIZE/$$STOCK/$$CONTEXT; \
+ $(INSTALL_DATA) $(srcdir)/$$icon $(DESTDIR)$(pkgdatadir)/$(BASE_VERSION)/icons/$$THEME/$$SIZE/$$STOCK/$$CONTEXT/stock_$$ICONFILE; \
+ done
uninstall-icons:
-for icon in $(public_icons); do \
@@ -173,6 +248,14 @@ uninstall-icons:
ICONFILE=`echo $$icon | cut -d_ -f4`; \
rm -f $(DESTDIR)$(pkgdatadir)/$(BASE_VERSION)/icons/$$THEME/$$SIZE/$$CONTEXT/$$ICONFILE; \
done
+ for icon in $(stock_private_icons); do \
+ THEME=`echo $$icon | cut -d_ -f1`; \
+ STOCK=`echo $$icon | cut -d_ -f2`; \
+ CONTEXT=`echo $$icon | cut -d_ -f3`; \
+ SIZE=`echo $$icon | cut -d_ -f4`; \
+ ICONFILE=`echo $$icon | cut -d_ -f6`; \
+ rm -f $(DESTDIR)$(pkgdatadir)/$(BASE_VERSION)/icons/$$THEME/$$SIZE/$$STOCK/$$CONTEXT/stock_$$ICONFILE; \
+ done
install-data-local: install-icons update-icon-cache