aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 4 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index ae56072674..3a5ff9af6d 100644
--- a/configure.in
+++ b/configure.in
@@ -1259,21 +1259,13 @@ dnl ********************
dnl KDE applnk directory
dnl ********************
AC_ARG_WITH(kde-applnk-path, [ --with-kde-applnk-path=PATH Location of KDE applnk files],
- [with_kde_applnk_path="$withval"])
+ [with_kde_applnk_path="$withval"],
+ [with_kde_applnk_path="no"])
if test x"$with_kde_applnk_path" != x"no"; then
if test -z "$with_kde_applnk_path"; then
- with_kde_applnk_path="$prefix/share/applnk"
- fi
- if test -d "$with_kde_applnk_path" ; then
- KDE_APPLNK_DIR="$with_kde_applnk_path"
- else
- AC_PATH_PROG(KDECONFIG, kde-config)
- if test -n "$KDECONFIG"; then
- KDE_APPLNK_DIR=`$KDECONFIG --expandvars --install apps`
- else
- KDE_APPLNK_DIR=""
- fi
+ with_kde_applnk_path="$datadir/applnk"
fi
+ KDE_APPLNK_DIR="$with_kde_applnk_path"
else
KDE_APPLNK_DIR=""
fi