aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in39
1 files changed, 2 insertions, 37 deletions
diff --git a/configure.in b/configure.in
index cb1d22989f..3304686ff0 100644
--- a/configure.in
+++ b/configure.in
@@ -374,45 +374,10 @@ AC_SUBST(GNOME_PRINT_CFLAGS)
GTKHTML_CFLAGS="`gnome-config --cflags gtkhtml`"
GTKHTML_LIBS="`gnome-config --libs gtkhtml`"
+GTKHTML_DATADIR=`gnome-config --moddatadir gtkhtml`
AC_SUBST(GTKHTML_CFLAGS)
AC_SUBST(GTKHTML_LIBS)
-
-if test x${prefix} = xNONE; then
- html_prefix=$ac_default_prefix
-else
- html_prefix=$prefix
-fi
-AC_MSG_CHECKING(for Editor.idl in `gnome-config --datadir`/gtkhtml or ${html_prefix}/share/gtkhtml)
-if test -f `gnome-config --datadir`/gtkhtml/Editor.idl; then
- GTK_HTML_EDITOR_IDL=`gnome-config --datadir`/gtkhtml/Editor.idl
- AC_MSG_RESULT(found - $GTK_HTML_EDITOR_IDL)
-else
- if test -f ${html_prefix}/share/gtkhtml/Editor.idl; then
- GTK_HTML_EDITOR_IDL=${html_prefix}/share/gtkhtml/Editor.idl
- AC_MSG_RESULT(found - $GTK_HTML_EDITOR_IDL)
- else
- AC_MSG_RESULT(not found)
- if test "x$GNOME_PATH" != "x" ; then
- for dir in `echo $GNOME_PATH | sed -e "s/:/ /" `; do
- AC_MSG_CHECKING(for Editor.idl in ${dir})
- if test -f ${dir}/share/gtkhtml/Editor.idl ; then
- GTK_HTML_EDITOR_IDL=${dir}/share/gtkhtml/Editor.idl
- AC_MSG_RESULT(found - $GTK_HTML_EDITOR_IDL)
- break
- else
- AC_MSG_RESULT(not found)
- fi
- done
- fi
-
- if test "x$GTK_HTML_EDITOR_IDL" = "x" ; then
- AC_MSG_ERROR(Editor.idl is required to compile Evolution; it's included in GtkHTML.
-You need GtkHTML built with html-editor-control)
- fi
- fi
-fi
-
-AC_SUBST(GTK_HTML_EDITOR_IDL)
+AC_SUBST(GTKHTML_DATADIR)
GNOME_VFS_LIBS="`gnome-config --libs vfs`"
GNOME_VFS_CFLAGS="`gnome-config --cflags vfs`"